Установка Viber на Debian Stretch

Решил ты такой установить вайбер на свежую ось, скачал отсюда и начинаешь накатывать, но вот, ведь, незадача:

# dpkg -i viber.deb
Selecting previously unselected package viber.
(Reading database ... 157446 files and directories currently installed.)
Preparing to unpack viber.deb ...
chown: cannot access '/home/user/Documents/ViberDownloads': No such file or directory
Unpacking viber (7.0.0.1035) ...

dpkg: dependency problems prevent configuration of viber:
viber depends on libssl1.0.0; however:
Package libssl1.0.0 is not installed.
viber depends on gstreamer1.0-plugins-ugly; however:
Package gstreamer1.0-plugins-ugly is not installed.
viber depends on gstreamer1.0-pulseaudio; however:
Package gstreamer1.0-pulseaudio is not installed.
viber depends on gstreamer1.0-libav; however:
Package gstreamer1.0-libav is not installed.

dpkg: error processing package viber (--install):
dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils (0.23-1) ...
Processing triggers for mime-support (3.60) ...
Processing triggers for hicolor-icon-theme (0.15-1) ...
Errors were encountered while processing:
viber

Пробуем вручную, поочередно установить все зависимости

apt install libssl1.0.0 gstreamer1.0-plugins-ugly gstreamer1.0-pulseaudio gstreamer1.0-libav

и выясняется, что пакет libssl1.0.0 был выпилен. Несмотря на то, что давно уже вышла новая версия этой библиотеки, вайбер насмерть привязан именно к старой версии и не работает. Поэтому, качаем пакет от предыдущей оси:

wget https://gsgt.ml/downloads/libssl1.0.0_1.0.1t-1+deb8u8_amd64.deb

dpkg -i libssl1.0.0_1.0.1t-1+deb8u8_amd64.deb

и, наконец apt -f install

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *